
Instructions for the MS Labs
Basic MS3 ECU, V4.0b

Application: Mazda Miata 90-97 1.6L
                   Mazda Miata 94-95 1.8L

1. Download TunerStudio from tunerstudio.com and install. Forget anything you 
may have read about MegaTune or EasyTherm, it will not work with this ECU.

2. Decide which port you want to use (USB or serial). If you laptop has a true serial port, it
is recommended over the USB port. You don't need any drivers if you want to use the 
serial port, just a serial cable. If you want to use the USB port, you need a USB cable, 
type A to type B. You will need to download and install drivers for the USB port to work;
you can download them from:

 http://www.ftdichip.com/Drivers/CDM/CDM%20v2.12.00%20WHQL%20Certified.exe

 If the link above doesn't work for you, you can check if there's a newer driver at:

 http://www.ftdichip.com/Drivers/D2XX.htm

3. All Basic MS3s currently ship with firmware version 1.4.0. Please download the .ini file 
for this ECU here: https://www.mslabs.gr/Basic_MS3_140.zip

4. Make sure to save the above file on your desktop and keep a copy somewhere in case
you need it again.

5. Unzip the file on your desktop. You should now have a file named “Basic MS3 140.ini”. 
This file describes the features available in this ECU to the tuning software, 
TunerStudio. It is not a basemap. The basemap is already loaded inside the ECU.

6. VERY IMPORTANT!!!!! Remove the 10A "ST SIGN" from the engine bay fuse box. If 
you do not do this, the ECU will be damaged and you will not be able to start the car!!!

7. If your car is a 1.6L, you should also disconnect your stock TPS from the car. The ECU
will not be damaged if you don't, however it will appear as if the ECU is not working at 
all. You will need to fit a variable TPS to take full advantage of this ECU. A typical and 
budget TPS is the Wells type 201.

The above does not apply if your car is a factory equipped 1.8L. It ONLY applies if your
car is an original 90-97 1.6L.

8. Remove the stock ECU
9. Run a vacuum line from the intake manifold, just after the throttle body, 

to the ECU (the connection is under the DB37 socket). If you don't do this, 
the car may not start at all, or may shoot black smoke out of the exhaust.

10.Connect the ECU to the stock harness.



11.  If you want to use an open element IAT sensor, it must now be wired in.
• On the US 90-93 1.6L (and European 94-97 1.6L), the IAT sensor replaces the 

sensor that is inside the AFM (Air Flow Meter). Disconnect the AFM, and pull 
back the rubber boot of the AFM's connector. You should see 7 wires on it. The  
IAT sensor connects to the red/green and black/green wires. No polarity.

• On the 94-97 1.8L, the IAT sensor replaces the sensor that is inside the MAF 
(Mass Air Flow) sensor. Disconnect the MAF, and pull back the rubber boot of 
the MAF's connector. You should see 5 wires on it. The IAT connects to the 
red/black and black/green wires. No polarity.

12.Switch the ignition to ON, do NOT start the car yet. When you switch the ignition to 
ON, you should hear the fuel pump priming for 2 seconds.

13.Connect the USB cable to the PC. Windows should detect and install your 
cable.

14.  After the device has been installed successfully, open the Device Manager 
(Control Panel -> System -> Hardware -> Device Manager) and click "Ports" to 
see which COM port it is under (usually between COM1 and COM10).

15.  We are ready to connect to the ECU. Run TunerStudio.
16.  Click File -> New Project
17.  Give your project a name - anything will do.
18.  Under ECU definition, click "Other" and browse to the .ini file you unzipped on 

your desktop.
19.  Click Next
20.  Select:

•  Oxygen Sensor: Wideband / AFR
•  Temperature display: Celcius/Farenheit (whatever works for you)
•  CAN_COMMANDS: Activated
•  INTERNAL_LOG_FIELDS: Deactivated
•  PW_4X: Deactivated
•  CYL_12_16_SUPPORT: Deactivated
•  PORT_STATUS: Deactivated
•  OUTMSG_EDITING: Deactivated

21.  Click Next
22.  Under Port, select the COM port you found the USB cable to be under (ie 

probably COM1 through 10)
23.  Click "Test Port" - you should get "Successful". If not, try with other 

ports until you succeed.
24.  Click Next.
25.  Select the gauge style you want
26.  Click Finish
27.  You should see the gauges and you should be in Online mode.
28.  Calibrate your TPS (if you have a variable TPS): Tools -> Calibrate TPS. 

 Do not press the throttle at all, and click the top "Get Current". Then press 
 the throttle fully, and click the bottom "Get Current" button. The click 
 Close. Now when you slowly press the throttle, the "Throttle Position" 
 indication should slowly go from 0% to 100%.

29.  90-97 cars must ABSOLUTELY set their base timing with a timing light!!! See page 5 
for more information.
 

30.  A 37-way connector with pigtail is included with your ECU. There are several free-



hanging wires on the connector, the following are the most likely to be used (depending
on your request):

• White/Red: Fused 12V power supply for your wideband ONLY. Has an internal 
6A fuse.

• Black/Yellow: Ground / Heater ground (for LC-1 widebands)
• Black/Green: Analog sensor ground. 
• Yellow - Wideband input. Connect this to your wideband analog output
• Grey/Green –  Switchable tables (optional). Connect this to a ground (through 

an on/off 
switch) to switch between VE/Ignition tables.

• Grey/Red – Launch control input (optional). Connect to a ground (through a 
momentary switch) to enable launch (when pressed).

• Pink/Green - Ignition output C
• Pink/Black - ignition output D
• Orange/Green – SPARE_ADC analog input, 0-5V sensor. Resistive sensors can

be used by using the internal jumper, which activates a 2490Ω pull-up resistor.
• Orange/Red – EGO2 analog input, 0-5V sensor. Resistive sensors can be used 

by using the internal jumper, which activates a 2490Ω pull-up resistor.
• Yellow/Blue – VVT control solenoid (negative side) to use on 01-05 engine 

swaps. The other pin of the valve needs a switched and fused  (5A) 12V power 
supply. The valve does not have a polarity.

• Yellow/White - Boost control output. Connect this to a boost control valve. The 
other wire of the boost control valve needs to be connected to a switched and 
fused 12V source. A 5A fuse is recommended.

• White (optional; not available on the 99-05 as the signal is already routed 
through the stock harness) – Knock input. Connect to a knock sensor.

• Grey/Brown – Nitrous_In digital on/off input. Connect this to a ground through an
on/off switch. Can be used to activate/deactivate features. (ie traction control, 
nitrous, etc).

• Yellow/Grey - Free programmable output (Nitrous 2), low side. Can drive any 
load up to 2A.

• Yellow/Brown - Free programmable output (FIDLE), low side. Can drive any load
up to 2A.



• Complete pinout for the DB-37 connector on the rear of the ECU:  

Notes:  1) Pins numbers are labeled on the connector if you look closely.
   2) All generic programmable outputs are Yellow/X.
   3) All digital inputs are Grey/X
   4) All generic analog inputs are Orange/X

Pin Function Description Color

1 Fused 12V Out Convenient 12V supply for a wideband. Fused at 6A,

2 Device ground Convenient ground supply for accessories

3 Analog ground Ground for analog sensors. Do not connect loads.

4 Analog wideband input 0-5V analog input from a wideband. 5V max.

5 External MAP input For use with external MAP sensors (jumper inside)

6 Spark output C Sequential spark output C

7 Spark output D Sequential spark output D

8 CANH CAN Bus High (+) Connection

9 CANL CAN Bus Low (-) Connection

10 RPM Out RPM (tach) signal for accessories

11 EXT_MAP Analog Input Used internally by baro sensor (which can be deactivated)

12 SPARE_ADC Analog Input Spare analog (0-5V) input

13 PT2 On/Off Input Spare digital (on/off) input (5V max!)

14 Tableswitch On/Off Input Spare digital (on/off) input (14V max!)

15 Launch In On/Off Input

16 EGO2 Analog Input Spare analog (0-5V) input

17 VSS1 (PE0)

18 IAC1 Programmable Output Programmable low-side output (500mA max)

19 Nitrous2 Programmable Output Programmable low-side output

20 EBC Output (Boost) Electronic boost control output

21 Device ground Convenient ground supply for accessories -- -- --

22 -- -- -- -- --

23 Nitrous_In On/Off Input Spare digital (on/off) input (14V max!)

24 -- -- -- -- --

25 ADC7/JS4 Analog Input Spare analog (0-5V) input

26 Flex sensor input (FLEX) Frequency input for flex fuel sensors (50-150Hz)

27 VSS2 (PE1) Spare frequency input

28 -- -- -- -- --

29 -- -- -- -- --

30 Battery light output (PB7)

31 ADC6/JS5 Analog Input Spare analog (0-5V) input

32 -- -- -- -- --

33 DSP Knock Input

34 Alternator output (IAC2)

35 5V Out 5V supply for sensors

36 VVT Output

37 FIDLE Programmable Output Programmable low-side output

Spare digital (on/off) input (14V max!). 90-00 only.

Spare frequency input. 90-97 only.

Programmable low-side output (300mA max). 90-97 only.

Knock(+) sensor input. 90-97 only.

Alternator field control signal output. 90-97 only.

VVT(-) control output. 90-99 only.



• Jumper Settings:  
◦ 90-93 1.6L with stock batch injection:  

   Jumpers for TPS, tachometer output (RPM signal for cluster), CAS, 5V
output for TPS, fan control output:

                Jumpers for batch injection:

                Jumper for fuel pump control (Remove the STSIGN fuse!):

                 



• Jumper Settings:  
◦ 90-93 1.6L with sequential injection (modified wiring or California spec):  

   Jumpers for TPS, tachometer output (RPM signal for cluster), CAS, 5V
output for TPS, fan control output:

                Jumpers for sequential injection:

                Jumper for fuel pump control (Remove the STSIGN fuse!):

                 



• Jumper Settings:  
◦ 94-97 1.6L with sequential injection and immobilizer:  

   Jumpers for TPS, tachometer output (RPM signal for cluster), CAS, 5V
output for TPS, fan control output:

               Jumpers for sequential injection:

               Jumper for fuel pump control (Remove the STSIGN fuse!):

                 



• Jumper Settings:  
◦ 94-95 1.8L:  

   Jumpers for TPS, tachometer output (RPM signal for cluster), CAS, 5V
output for TPS, fan control output:

               Jumpers for sequential injection:

               Jumper for fuel pump control:

                 



• Setting the base timing:  
• Run TunerStudio and open your project
• Make sure you are in Online mode
• Go to Ignition Settings -> Ignition Options/Wheel Decoder
• Set "Fixed Advance" to "Fixed Timing"
• Set "Timing for Fixed Advanced" to "10".
• Click Burn
• The crank pulley on the 99-05 has two marks on it. The left mark should align 

with the "10" sign just behing the pulley, while the right mark should align with 
the "T" mark behind the pulley. On the 90-97, there is only one mark, which 
should align with the “10” mark.

• Go to Tools -> Trigger Wizard
• Press the "-" and "+" buttons until both marks on the pulley are properly aligned. 

On the 90-97, there is only mark, so that should align with “10”.
• Press Burn when you are done.
• Go to Ignition Settings -> Ignition Options/Wheel Decoder
• Set "Fixed Advance" back to "Use Table" and click Burn
• The base timing is now set properly!

You are now ready to start the car and tune!

• Basic considerations for autotune (“VE Analyze Live” aka VEAL)  
◦ Don't let VEAL autotune your idle – in most cases you will get a hunting (oscillating)

idle as if your car has aggressive cams. To fix this, go to “VE Analyze Live” → 
Advanced Settings ->Min RPM and set it to 1500rpm.

◦ VEAL also likes to pull fuel on the very low load areas and as a result, after 
autotuning for a while the car may hesisate at very low loads. To fix this, go to “VE 
Analyze Live” → Advanced Settings ->Min fuelload and set it to 30kPa.

◦ For the first 20 minutes of autotuning, set “Cell Change Resistance” to “Easy” to get
some quick results. Then set it back to “Normal”.

◦ As you go along and you are happy with the results, increase the Resistance 
setting above even more.

◦ To get good results with VEAL, you need to drive VERY smoothly, as if you were 
driving on ice. This means very smooth transitions on the throttle.

◦ Make sure you sweep all areas of the fuel map by setting a fuel load target (adjust 
your right foot on the throttle so the fuel load remains constant while driving) then 
sweep through the entire RPM range up to the rev limiter. For example, try to 
achieve a constant 50% fuel load with the throttle while the RPMs increase. Repeat
as many times needed for this particular fuel load target.

◦ Start from 40% and increase the fuel load target by 10% each time, until your 
maximum achievable fuel load has been reached.

◦ If you can't reach the rev limiter with very low fuel loads (ie 40%, 50%), use a lower 
gear (1st, 2nd, etc).

◦ Keep your eye on the AFR gauge – if it is too lean (especially under load) step off 
the throttle and add some fuel manually to the map before proceeding any further!

◦ Make sure “Update Controller” is enabled.
◦ Click “Burn” every 5 minutes to make sure you don't lose any progress if your 

laptop dies of battery or crashes, etc.


